Настройка vlan на коммутаторе Huawei Quidway

Локальная сеть (LAN) может быть разделена на несколько логических сетей, называемых Virtual LAN (VLAN). VLAN'ы используются для объединения устройств которые должны взаимодействовать друг с другом на 2 уровне модели OSI в единую локальную сеть (широковещательный домен) и отделения их от других устройств. Рассмотрим настройку vlan на коммутаторах Huawei Quidway. Для примера используем коммутатор s2300, однако описанные ниже настройки применимы и к более старшим моделям.

Создание vlan на коммутаторе Huawei Quidway.

Для создания vlan на коммутаторах семейства Huawei Quidway необходимо прежде всего определиться с тэгом (vlan id). Далее, заходим в режим системных настроек system-view. Выполняем команду vlan [vlan-id] для создания соответствующего vlan. При желании можно добавить описание vlan при помощи команды description.

<switch_1>system-view
Enter system view, return user view with Ctrl+Z.
[switch_1]vlan 2
[switch_1-vlan2]description Service_vlan
[switch_1-vlan2]quit
[switch_1]quit

Для создания нескольких vlan'ов одновременно используется команда vlan batch [vlan-id1 to vlan-id2]

Для проверки конфигурации используется команда display vlan [vlan-id]. Команда, в частности, отображает какой порт в каком режиме добавлен в vlan. Об этом в следующем разделе статьи.

<switch_1>display vlan 2
* : management-vlan
---------------------
VLAN ID Type Status MAC Learning Broadcast/Multicast/Unicast Property
--------------------------------------------------------------------------------
2 common enable enable forward forward forward default
----------------
Untagged Port: Ethernet0/0/1 Ethernet0/0/2
Ethernet0/0/3 Ethernet0/0/4
Ethernet0/0/5 Ethernet0/0/6
Ethernet0/0/7
----------------
Tagged Port: GigabitEthernet0/0/1
----------------
Interface Physical
Ethernet0/0/1 DOWN
Ethernet0/0/2 DOWN
Ethernet0/0/3 DOWN
Ethernet0/0/4 DOWN
Ethernet0/0/5 DOWN
Ethernet0/0/6 DOWN
Ethernet0/0/7 DOWN
GigabitEthernet0/0/1 DOWN

 

Добавление интерфейсов в vlan на коммутаторе Huawei Quidway.

Интерфейсы коммутатора Huawei можно разделить на следующие основные типы:

  • Access: access порт может быть добавлен только в один vlan, который называется default vlan. К access портам обычно подключаются пользовательские устройства.
  • Trunk: trunk порт может быть добавлен в несколько vlan'ов и обычно используется для соединения с другими сетевыми устройствами.

Как правило, порты добавляются в vlan'ы в зависимости от обрабатываемых сервисов. Например к портам Interface 1 и Interface 2 подключены пользователи с доступом в сеть Internet, к портам Interface 3 и Interface 4 подключены устройства VoIP. Таким образом, порты Interface 1, Interface 2 и Interface 3, Interface 4 должны быть подключены к разным vlan.

 

Добавление access порта в vlan.

Заходим в режим системных настроек system-view, далее в режим настройки интерфейса interface [interface-type interface-number].  Устанавливаем тип интерфейсного линка в access: port link-type access. Добавляем нужный vlan командой port default vlan [vlan-id]. Выходим из режима конфигурации порта командой quit и проверяем настройки интерфейса командой display current-configuration interface  [interface-type interface-number]

<switch_1>system-view
Enter system view, return user view with Ctrl+Z.
[switch_1]interface Ethernet0/0/1
[switch_1-Ethernet0/0/1]port link-type access
[switch_1-Ethernet0/0/1]port default vlan 2
[switch_1-Ethernet0/0/1]quit
[switch_1]quit
<switch_1>display current-configuration interface Ethernet 0/0/1
#
interface Ethernet0/0/1
port link-type access
port default vlan 2
undo ntdp enable
undo ndp enable
#

Добавление trunk порта в vlan.

Заходим в режим системных настроек system-view, далее в режим настройки интерфейса interface [interface-type interface-number].  Устанавливаем тип интерфейсного линка в trunk: port link-type trunk. Добавляем нужные vlan'ы командой port trunk allow-pass vlan  [vlan-id1 to vlan-id2]. После этого порт будет добавлен в один или несколько vlan'ов в режиме trunk. Выходим из режима конфигурации порта командой quit и проверяем настройки интерфейса командой display current-configuration interface [interface-type interface-number].

<switch_1>system-view
Enter system view, return user view with Ctrl+Z.
[switch_1]interface Ethernet0/0/1
[switch_1-Ethernet0/0/1]port link-type trunk
[switch_1-Ethernet0/0/1]port trunk allow-pass vlan 2 3
[switch_1-Ethernet0/0/1]quit
[switch_1]quit
<switch_1>display current-configuration interface Ethernet 0/0/1
#
interface Ethernet0/0/1
port link-type trunk
port trunk allow-pass vlan 2 to 3
undo ntdp enable
undo ndp enable
#

В статье рассмотрена настройка vlan на коммутаторе Huawei Quidway. В моей предыдущей статье вы можете прочитать про базовую настройку коммутатора Huawei Quidway и скачать файл конфигурации для коммутатора Huawei Quidway S2309TP-SI.

 

Андрей

10.06.2017

Понравилась статья? Поделитесь с друзьями!

Добавить комментарий


Защитный код
Обновить