Базовая настройка коммутатора Huawei Quidway

Сетевое оборудование компании Huawei занимает все более прочные позиции на российском рынке. Тем не менее, у многих системных администраторов еще недостаточно опыта для его качественной настройки. Статья по базовой настройке коммутаторов Huawei Quidway призвана восполнить данный пробел.

В статье мы рассмотрим настройку коммутатора Huawei Quidway S2309TP-SI с версией прошивки V100R005C01SPC100.

<switch_1>display version
Huawei Versatile Routing Platform Software
VRP (R) software, Version 5.70 (S2300 V100R005C01SPC100)
Copyright (C) 2000-2011 HUAWEI TECH CO., LTD
Quidway S2309TP-SI Routing Switch ...

Настройку произведем в соответствии с топологией изображенной ниже сети. В конце статьи вы сможете скачать файл конфигурации для использования в вашем коммутаторе.

 

 

Топология тестовой сети

Топология тестовой сети для Huawei Quidway s2300

Как видно на приведенной схеме, тестовая сеть содержит два vlan. 

vlan 1 - выделенная логическая сеть для управления оборудованием. Используемая подсеть 192.168.1.0 / 24. Шлюз 192.168.1.1, коммутатору Quidway присвоен IP адрес 192.168.1.4.

vlan 2 - выделенная логическая сеть для предоставления сервиса конечным пользователям (в нашем случае, "сервисная" подсеть не имеет терминации на Quidway, поэтому используемая в ней адресация не важна).

На коммутаторе Huawei Quidway s2300 используем порт GigabitEthernet0/0/1 как входящий магистральный порт, порты Ethernet0/0/1 - Ethernet0/0/8 используем для подключения конечных пользователей.

 

 

Общие настройки Huawei Quidway

Большинство настроек коммутатора Quidway выполняются в привилегированном режиме. Вход в привилегированный режим выполняется командой system-view, выход - командой quit. При входе в привилегированный режим приглашение командной строки меняется на [system_name]. Непривилегированный режим характеризуется приглашением <system_name>.

Настройка имени устройства

[quidway]sysname switch_1

Настройка даты и времени

Настройка времени и даты на коммутаторе выполняется не в привилегированном режиме. Необходимо указать часовой пояс и, непосредственно, дату и время

<switch_1>clock timezone EKT add 05:00:00
<switch_1>clock datetime 18:19:00 2015-12-02

Проверка установленных даты и времени производится с помощью команды display clock

<switch_1>display clock
2015-12-02 18:19:08
Wednesday
Time Zone(EKT) : UTC+05:00

Отключение неиспользуемых сервисов

Отключаем http сервер.

[switch_1]undo http server enable

Мы не планируем организовывать кластер из коммутаторов Quidway, поэтому отключаем кластерные функции и протоколы NDP (Neighbor Discovery Protocol - используется в кластере для сбора информации о подключенных соседях) и NTDP (Network Topology Discovery Protocol - используется для построения топологии в кластере).

[switch_1]undo cluster enable
[switch_1]undo ntdp enable
[switch_1]undo ndp enable

 

 

Настройка доступа на Huawei Quidway

Настройка правил аутентификации и авторизации

Настройки аутентификации и авторизации оставляем без изменения:

[switch_1]aaa
[switch_1-aaa]authentication-scheme default
[switch_1-aaa]authorization-scheme default
[switch_1-aaa]accounting-scheme default
[switch_1-aaa]domain default
[switch_1-aaa]domain default_admin

Настройка учетной записи

Добавляем пользователя huawei. Задаем для пользователя пароль, указываем допустимый уровень привилегий и используемый сервис. В нашем случае, указываем сервис ssh. Небезопасный протокол telnet не используем. Также, отключаем созданного по умолчанию пользователя admin.

[switch_1]aaa 
[switch_1-aaa]local-user huawei password cipher [PASSWORD]
[switch_1-aaa]local-user huawei privilege level 3
[switch_1-aaa]local-user huawei service-type ssh
[switch_1-aaa]undo local-user admin

Настройка удаленного управления по SSH

В моей предыдущей статье уже была подробно описана настройка SSH на коммутаторах Huawei Quidway, поэтому в данном пункте я лишь кратко приведу пункты конфигурации.

[switch_1]stelnet server enable 
[switch_1]ssh user huawei
[switch_1]ssh user huawei authentication-type password
[switch_1]ssh user huawei service-type all
[switch_1]user-interface vty 0 4
[switch_1-ui-vty0-4]authentication-mode aaa
[switch_1-ui-vty0-4]user privilege level 3
[switch_1-ui-vty0-4]idle-timeout 30 0
[switch_1-ui-vty0-4]protocol inbound ssh

Настройка подключения по консоли

Для подключения к Quidway по консоли используем локальную аутентификацию. Задаем
подключившемуся пользователю максимальный приоритет. Устанавливаем время простоя сессии в 30 минут.

[switch_1]user-interface con 0
[switch_1-ui-console0]authentication-mode aaa
[switch_1-ui-console0]user privilege level 15
[switch_1-ui-console0]idle-timeout 30 0

Настройка SFTP сервера для доступа к файлам во flash памяти коммутатора

Для безопасного доступа к flash памяти Huawei Quidway по SFTP необходимо настроить доступ по SSH как описано выше и включить SFTP сервер на коммутаторе. В нашем примере, для доступа по SFTP используется учетная запись huawei (совпадает с учетной записью для доступа по SSH).

[switch_1]sftp server enable

 

Настройка VLAN и портов в Huawei Quidway.

Создание VLAN

Создаем на Quidway два vlan и указываем их название. Как уже указывалось выше, в vlan 1 будем осуществлять управление коммутатором, в vlan 2 будет предоставляться сервис.

[switch_1]vlan 1
[switch_1-vlan1]description Management
[switch_1]vlan 2
[switch_1-vlan2]description Service

Cоздание интерфейса vlanif для удаленного управления

Создаем виртуальный интерфейс Vlanif 1 и назначаем ему ip адрес. Интерфейс будет
использоваться для удаленного доступа на коммутатор.

[switch_1]interface Vlanif1
[switch_1-Vlanif1]description Management
[switch_1-Vlanif1]ip address 192.168.1.4 255.255.255.0

Настройка магистрального порта

В магистральном порту прокидываем два vlan в тэгированном виде. Для этого переводим порт в режим trunk и разрешаем прохождение vlan 1 и 2. При просмотре конфигурации порта командой display configuration interface GigabitEthernet0/0/1, vlan 1 не отображается.

[switch_1]interface GigabitEthernet0/0/1
[switch_1-GigabitEthernet0/0/1]description Uplink
[switch_1-GigabitEthernet0/0/1]port link-type trunk
[switch_1-GigabitEthernet0/0/1]port trunk allow-pass vlan 2
[switch_1-GigabitEthernet0/0/1]undo ntdp enable
[switch_1-GigabitEthernet0/0/1]undo ndp enable

Настройка пользовательских портов

Последовательно настраиваем порты Ethernet0/0/1 - Ethernet0/0/8, которые будут использоваться для предоставления сервиса конечным пользователям. Для примера приведу конфигурацию порта Ethernet0/0/1. Для остальных портов она будет аналогична. Переводим порт в режим access, чтобы метка тэга vlan снималась на порту при отправке их конечному устройству. Добавляем Vlan 2.

[switch_1]interface Ethernet0/0/1
[switch_1-Ethernet0/0/1]description Access_port
[switch_1-Ethernet0/0/1]port link-type access
[switch_1-Ethernet0/0/1]port default vlan 2
[switch_1-Ethernet0/0/1]undo ntdp enable
[switch_1-Ethernet0/0/1]undo ndp enable

Подробнее про настройку vlan на коммутаторе Huawei вы можете прочитать в моей статье Настройка vlan на коммутаторе Huawei Quidway.

После настройки коммутатора Huawei Quidway, не забудьте сохранить конфигурацию при помощи команды save (выполняется в непривилегированном режиме). В противном случае, все выполненные настройки будут потеряны при перезагрузке коммутатора.

 

Файл конфигурации Huawei Quidway

Ниже приведен файл конфигурации для коммутатора Huawei Quidway S2309TP-SI, соответствующий описанным выше настройкам. В приведенной конфигурации используется логин huawei и пароль Huawei123. В моей предыдущей статье вы можете прочитать про то, как безопасно подменять файл конфигурации на коммутаторах Huawei Quidway.

Файл конфигурации Huawei Quidway S2309TP-SIvrpcfg.zip

 

Итак, в статье мы рассмотрели базовую настройку коммутатора Huawei Quidway s2300. Приведенная конфигурация, при необходимости, масштабируется на другие коммутаторы семейства Huawei Quidway. 
Если у вас остались какие-нибудь вопросы - задавайте их в комментариях, я обязательно постараюсь на них ответить. Приятной работы!

 

Андрей

10.12.2015

Понравилась статья? Поделитесь с друзьями!

Добавить комментарий


Защитный код
Обновить