Настройка vlan на коммутаторе Cisco

Локальная сеть (LAN) может быть разделена на несколько логических сетей, называемых Virtual LAN (VLAN). VLAN'ы используются для объединения устройств которые должны взаимодействовать друг с другом на 2 уровне модели OSI в единую локальную сеть (широковещательный домен) и отделения их от других устройств. Рассмотрим настройку vlan на коммутаторах Cisco. Для примера используем коммутатор Cisco Catalyst c2950, однако описанные ниже настройки применимы и к другим моделям.

Создание vlan на коммутаторе Cisco.

Для создания vlan на коммутаторах семейства Cisco Catalyst необходимо прежде всего определиться с тэгом (vlan id). Значение vlan id может быть от 1 до 4096. Далее, заходим в привилегированный, затем в конфигурационный режимы при помощи команд enable и configure terminal. Выполняем команду vlan [vlan-id] для создания соответствующего vlan. При желании можно добавить описание vlan при помощи команды name.

sw01>enable
Password: *******
sw01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
sw01(config)#vlan 2
sw01(config-vlan)#name Service_vlan
sw01(config-vlan)#exit
sw01(config)#exit
sw01#exit

Для проверки конфигурации используется команда show vlan id [vlan-id]. Команда, в частности, отображает какой порт в каком режиме добавлен в vlan. Об этом в следующем разделе статьи. Также, можно посмотреть все существующие на коммутаторе vlan'ы при помощи команды show vlan.

sw01#show vlan id 2

VLAN  Name                              Status   Ports
------  -------------------------------- --------- -------------------------------
2       Service_vlan                     active   Fa0/15

VLAN Type  SAID     MTU Parent  RingNo BridgeNo Stp BrdgMode Trans1 Trans2
------  -----  ---------- -----  --------  -------- ----------- ---- ------------  ------    ------
2       enet  100002  1500 -          -         -            -     -               0         0

Remote SPAN VLAN
------------------------
Disabled

Primary Secondary Type              Ports
--------- ------------- ----------------- ------------------------------------------

 

Добавление интерфейсов в vlan на коммутаторе Cisco.

Интерфейсы коммутатора Cisco можно разделить на следующие основные типы:

  • Access: access порт может быть добавлен только в один vlan, который называется default vlan. К access портам обычно подключаются пользовательские устройства. 
  • Trunk: trunk порт может быть добавлен в несколько vlan'ов и обычно используется для соединения с другими сетевыми устройствами.

Как правило, порты добавляются в vlan'ы в зависимости от обрабатываемых сервисов. Например к портам Interface 1 и Interface 2 подключены пользователи с доступом в сеть Internet, к портам Interface 3 и Interface 4 подключены устройства VoIP. Таким образом, порты Interface 1, Interface 2 и Interface 3, Interface 4 должны быть подключены к разным vlan.


Добавление access порта в vlan на коммутаторе Cisco.

Заходим в конфигурационный режим с помощью команды configure terminal, далее в режим настройки интерфейса interface [interface-type interface-number]. Устанавливаем тип интерфейсного линка в access: switchport mode access. Добавляем нужный vlan командой switchport access vlan [vlan-id]. Выходим из режима конфигурации порта командой exit и проверяем настройки интерфейса командой show running-config interface [interface-type interface-number] 

sw01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
sw01(config)#interface fastEthernet 0/15
sw01(config-if)#switchport mode access
sw01(config-if)#switchport access vlan 2
sw01(config-if)#exit
sw01(config)#exit
sw01#show running-config interface fastEthernet 0/15
Building configuration...

Current configuration : 84 bytes
!
interface FastEthernet0/15
switchport access vlan 2
switchport mode access
end


Добавление trunk порта в vlan на коммутаторе Cisco.

Заходим в конфигурационный режим с помощью команды configure terminal, далее в режим настройки интерфейса interface [interface-type interface-number]. Устанавливаем тип интерфейсного линка в trunk: switchport mode trunk. Добавляем нужные vlan'ы командой switchport trunk allowed vlan [vlan-id1, vlan-id2]. После этого порт будет добавлен в один или несколько vlan'ов в режиме trunk. Выходим из режима конфигурации порта командой exit и проверяем настройки интерфейса командой show running-config interface [interface-type interface-number].

sw01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
sw01(config)#interface fastEthernet 0/16
sw01(config-if)#switchport mode trunk
sw01(config-if)#switchport trunk allowed vlan 2,5
sw01(config-if)#exit
sw01(config)#exit
sw01#show running-config interface fastEthernet 0/16
Building configuration...

Current configuration : 92 bytes
!
interface FastEthernet0/16
switchport trunk allowed vlan 2,5
switchport mode trunk
end

В статье рассмотрена настройка vlan на коммутаторе Cisco. Если у вас остались какие-нибудь вопросы - задавайте их в комментариях, я обязательно постараюсь на них ответить. Приятной работы!

 

Андрей

03.07.2017

Понравилась статья? Поделитесь с друзьями!

Добавить комментарий


Защитный код
Обновить